I am new to robotics.Recently came into contact code.So the teacher let me use the Serial port app for Android to enter the opcode.But the robot did not have any reaction.


I use the Communications Cable with Adapter in android phone. App Use [DroidTerm: USB Serial port]

Serial Port Settings Baud: 115200 (19200 also used) Data bits: 8 Parity: None Stop bits: 1 Flow control: None


I try to enter opcode, but no response.--> enter:128,135,134..... But it did not show any reaction to the phone and robot. I hope according to Opcode instructions to control robots to make the specified action.

  • You had mentioned before the edit that you were using the "iRobot® Create® 2 Open" manual. What robot are you using? Is it an iRobot Create 2? – Chuck Jun 16 '16 at 14:03
up vote 2 down vote accepted

The robot's baud-rate may not be the default rate of 115200. Try resetting the robot (by holding dock and spot for 10 seconds, or removing the battery). This will reset the baud-rate back to 115200.

If that doesn't work, try connecting the robot to a computer and using RealTerm or some other serial program and send the same data.

Also, when sending the data bytes, make sure they are being sent as raw 'numbers' (not ASCI).

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.