Rosanswers logo

Hi! I'm fairly new to gazebo, robot modelling and plugins, and I'm now trying to make a small 4wd rover, but I have some problems with the plugins. I'm not able to make the libgazebo_ros_skid_steer_drive plugin work in my urdf file in ROS2, and I get the following error msg:

[gazebo-1] [Err] [Plugin.hh:212] Failed to load plugin libgazebo_ros_skid_steer_drive.so: libgazebo_ros_skid_steer_drive.so: cannot open shared object file: No such file or directory

This is what I have tried to put in my urdf file, but it is only a copy from the sdf version found in gazebo-ros-pkg. I have tried other syntax versions aswell, but with no luck.

    <plugin name="two_wheeled_robot_diff_drive" filename="libgazebo_ros_skid_steer_drive.so">

    <!-- Number of wheel pairs -->
    <!-- wheels0 -->

    <!-- wheels1-->

    <!-- kinematics -->


    <!-- limits -->

    <!-- output -->


I have installed ros-foxy-gazebo-ros-pkgs and I can make the libgazebo_ros_diff_drive plugin work. Can anyone help me to fix the problem?

Originally posted by knuttu on ROS Answers with karma: 36 on 2021-12-17

Post score: 1


1 Answer 1


Rosanswers logo

So it turns out that the libgazebo_ros_skid_steer_drive plugin was replaced with the libgazebo_ros_diff_drive plugin from ROS1 to ROS2. In other words, the parameters in my file were right, but the filename wasnt. When I changed it to


it worked perfectly.

Originally posted by knuttu with karma: 36 on 2021-12-17

This answer was ACCEPTED on the original site

Post score: 1

Original comments

Comment by osilva on 2021-12-20:
Glad it worked. Thank you for sharing your answer


Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.