0
$\begingroup$

Rosanswers logo

I am trying to build this package on ROS2. I was getting some errors with tf2_geometry_msgs but I resolved that by editing the CMake file and package.xml. Apart from this, I am getting the following error that I cannot get rid of:

--- stderr: ui_for_debug_and_demo
CMake Error at CMakeLists.txt:28 (find_package): By not providing "FindQt5Quick.cmake" in CMAKE_MODULE_PATH this project has asked CMake to find a package configuration file provided by "Qt5Quick", but CMake did not find one.

Could not find a package configuration file provided by "Qt5Quick" with any of the following names:

Qt5QuickConfig.cmake
qt5quick-config.cmake

Add the installation prefix of "Qt5Quick" to CMAKE_PREFIX_PATH or set "Qt5Quick_DIR" to a directory containing one of the above files. If "Qt5Quick" provides a separate development package or SDK, be sure it has been installed.

I installed Qt5 from multiple sources and even tried giving the cmake path by this command:

export CMAKE_PREFIX_PATH=/opt/Qt5.10.1/5.10.1/gcc_64/lib/cmake

However this error keeps persisting and I am unable to build the packages. Please help with this


Originally posted by ronak_bhanushali_iafsm on ROS Answers with karma: 1 on 2021-12-13

Post score: 0


Original comments

Comment by osilva on 2021-12-14:
If you already post in stack overflow please don’t duplicate asking again in this forum.

https://stackoverflow.com/questions/70330777/colcon-build-fails-due-to-qt5-error-installed-qt5-but-still-getting-the-same-er

$\endgroup$

1 Answer 1

0
$\begingroup$

Rosanswers logo

Do you have Qt5 installed?

sudo apt-get install qtbase5-dev
sudo apt-get install qtdeclarative5-dev

Based on this post from StackOverflow.


Originally posted by ljaniec with karma: 3064 on 2021-12-15

This answer was ACCEPTED on the original site

Post score: 0

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.