0
$\begingroup$

Rosanswers logo

Hi everyone. I'm in ROS Melodic and I'm working with OpenCV 4.5.3 for xfeatures2d. At the end of catkin_make, i have this warnings:

/usr/bin/ld: warning: libopencv_imgproc.so.4.5, needed by /usr/local/lib/libopencv_xfeatures2d.so.4.5.3, may conflict with libopencv_imgproc.so.3.2

I've seen many questions for this warnings, that suggest to clone cv_bridge from source code. But I don't understand I specify OpenCV version in my cv_bridge. I've tried to change CMakeFile of cv_bridge like this:

find_package(OpenCV 3 REQUIRED -> find_package(OpenCV 4 REQUIRED

but can't build.


Originally posted by Elektron97 on ROS Answers with karma: 11 on 2021-11-29

Post score: 1

$\endgroup$

1 Answer 1

0
$\begingroup$

Rosanswers logo

I found a solution in Github:

In catkin_ws/src:

git clone https://github.com/fizyr-forks/vision_opencv/tree/opencv4
cd vision_opencv
git checkout opencv4

Originally posted by Elektron97 with karma: 11 on 2021-11-29

This answer was ACCEPTED on the original site

Post score: 0


Original comments

Comment by osilva on 2021-11-29:
Thank you for sharing

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.