0
$\begingroup$

Rosanswers logo

Hi,

I am working through the urdf_tutorials and I found that rviz doesn't show the cylinder model correctly, it only shows the circle on the floor and isn't 'extruded'. The box and sphere work fine and are shown in rviz. There aren't any errors shown in the terminal.

Link to rviz display

I am using: ROS2 - galactic, RVIZ2 version Alpha

Packages: joint_state_publisher joint_state_publisher_gui

OS: Ubuntu 20.04.3 LTS 64bit with kernel 3.36.8

It looks like this is a bug in the parser? Thanks for the help!


Originally posted by laziest_robot on ROS Answers with karma: 41 on 2021-11-03

Post score: 0


Original comments

Comment by osilva on 2021-11-03:
Looks like a repeat question. Take a look at https://answers.ros.org/question/374069/rviz2-only-render-boxes/

Comment by laziest_robot on 2021-11-04:
Thanks osilva, putting LC_NUMERIC="en_US.UTF-8" to .bashrc solved my issue.

echo 'export LC_NUMERIC="en_US.UTF-8"' >>~/.bashrc

Comment by osilva on 2021-11-04:
Glad to hear it worked

$\endgroup$

1 Answer 1

0
$\begingroup$

Rosanswers logo

Putting LC_NUMERIC="en_US.UTF-8" to .bashrc solved my issue:

echo 'export LC_NUMERIC="en_US.UTF-8"' >>~/.bashrc

I have adjusted the ROS2 documentation to include this step. Pull Request


Originally posted by laziest_robot with karma: 41 on 2021-12-18

This answer was ACCEPTED on the original site

Post score: 2

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.