0
$\begingroup$

Rosanswers logo

In the first lecture of AutowareAuto, I tried to run 7 debugging commands in the ade environment according to the lecture notes. But after I run the first 5 sentences, then run: ros2 run point_cloud_filter_transform_nodes point_cloud_filter_transform_node_exe... After that, point clouds still cannot appear on Rviz.

I see no error output, only after running the second sentence rviz2 -d /home/${USER}/autowareclass2020/code/src/01_DevelopmentEnvironment/aw_class2020.rviz, some warnings are displayed as follows:

*QStandardPaths: XDG_RUNTIME_DIR not set, defaulting to '/tmp/runtime-gavinfang'

rviz2: Stereo is NOT SUPPORTED

rviz2: OpenGl version: 3.1 (GLSL 1.4)

rviz2: Stereo is NOT SUPPORTED

Parsing robot urdf xml string.

Warning: Invalid frame ID "base_link" passed to canTransform argument target_frame - frame does not exist at line 133 in /tmp/binarydeb/ros-foxy-tf2-0.13.9/src/buffer_core.cpp

Warning: Invalid frame ID "base_link" passed to canTransform argument target_frame - frame does not exist at line 133 in /tmp/binarydeb/ros-foxy-tf2-0.13.9/src/buffer_core.cpp

Warning: Invalid frame ID "base_link" passed to canTransform argument target_frame - frame does not exist at line 133 in /tmp/binarydeb/ros-foxy-tf2-0.13.9/src/buffer_core.cpp

Warning: Invalid frame ID "base_link" passed to canTransform argument target_frame - frame does not exist at line 133 in /tmp/binarydeb/ros-foxy-tf2-0.13.9/src/buffer_core.cpp

Warning: Invalid frame ID "base_link" passed to canTransform argument target_frame - frame does not exist at line 133 in /tmp/binarydeb/ros-foxy-tf2-0.13.9/src/buffer_core.cpp*

I wonder if this affects point cloud generation? hi, everyone, can you help me ?


Originally posted by gavin fang on ROS Answers with karma: 3 on 2021-11-02

Post score: 0


Original comments

Comment by xmfcx on 2021-11-05:
Could you add autoware tag to the question please for others to easily find this question?

Comment by gavin fang on 2021-11-05:
Thanks and already done

$\endgroup$

1 Answer 1

0
$\begingroup$

Rosanswers logo

A recent version of rviz2 on foxy had issues visualizing point clouds, you could try sudo apt update ; sudo apt dist-upgrade and rerun the command that opens up rviz2 ?


Originally posted by xmfcx with karma: 96 on 2021-11-05

This answer was ACCEPTED on the original site

Post score: 0


Original comments

Comment by gavin fang on 2021-11-05:
Thanks a lot! It's work now after update. So it's not nvidia driver issue. and don't forget add /lidar_front/points_raw topic, thanks!

BR Gavin Fang

Comment by xmfcx on 2021-11-05:
I'm glad it solved your problem! Could you mark this answer as correct with the tick symbol on the left? Thanks!

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.